Search

maxichimaximind

Endless Openmindedness

Category

NEPA Chronicles

These are the Posts I come up with when the Power goes off…..

Customer Service in Nigerian Banks

Every successful business organization knows the value of their customers and the need to constantly keep them happy. A happy customer base usually implies satisfaction with the service provided or goods purchased. And this translates to more patronage from loyal customers and in turn increase in the overall customer base. When the reverse is the case, businesses lose out on potential profit.

This scenario doesn’t seem to apply to Nigerian banks because Nigeria is densely populated. The demand from the populace on these banks is so overwhelming that these banks can get away with providing the worst possible customer service ever and still experience a growth in their customer base. The problem isn’t in the lack of capacity to provide a better customer experience, because Nigeria is filled with qualified unemployed youths that can handle such roles. The problem lies in the unwillingness of the banks to take their customers seriously enough to ensure that they are satisfied with the service provided. Customer service is obviously not a priority because if it were, there would be more than two customer service agents per bank. Visit any bank in Nigeria, you will only find two customer service agents attending to a swarm of customers. If you find more than two customer service agents in a bank, then it must be your lucky day.

overpopulation
Densely Populated Customer Base

Due to the swarm of customers hovering around the usual two customer service agents per bank, customers hardly get the level of service they deserve. The agents lose their courtesy and treat the customers like they are a burden upon them. If you happen to be a rich customer and know one or two of the bank staff, you can avoid all this stress, because you are taken into an office and offered the kind of service every customer should be receiving in the first place.

Crowded Hall
Crowded Banking Halls

I experienced such horrible service the other day at an Ecobank branch. The problem started when I tried to purchase groceries using my Ecobank Mastercard. The card was declined so I had to pay with another card. Then I tried using the card to withdraw some cash from an ATM, I got the following error “Issuer or Switch unavailable”. I then visited an Ecobank ATM and got the same error. At that point I was fed up and decided to visit a branch to withdraw over the counter. On getting to the branch, I was told I couldn’t use a withdrawal slip because I operate a current account. So I had to speak with a customer service agent at the branch there. The customer service agent was swarmed with customers as usual and I had to wait for at least 30 minutes before I could even get the chance to speak with the agent. I was eventually told to write an application letter to withdraw over the counter. I did this and was able to withdraw the money I needed only to be charged for that withdrawal. So this bank has failed to provide the service they were suppose to provide me with in the first place, put me through the stress of speaking to an over-crowded customer service agent and then charge me for all their troubles. Needless to say, I am not a happy customer and I will not be needing their service any more. The sad part is that they don’t even care that I am leaving because this is the normal kind of service they put their customers through and complaining yields more stress than resolutions. These issues aren’t exclusive to Ecobank, other people have faced similar or worse services at the hands of other banks. I certainly have faced similar issues at other banks but this is the most recent and therefore the most annoying for now.

Crowded bank
Another Crowded Bank

The customer service problem is not a difficult one to solve. If only the managers of these banks make customer service a priority. I know the the amount of customers some of these banks have to deal with can be overwhelming but if it is a priority, it can be resolved. For example, Industrial attachment students can be trained to offer these services at a very cheap rate if cost is a problem. NYSC Corpers are also another option, they can be exclusively trained to offer the best of customer service experiences still at a cheap rate. So you see, there’s really no excuse for the horrible service experienced by customers of Nigerian banks.

Representing the Nigerian Youth in its Governance

On Sunrise daily — A current affairs discussion program aired last Friday 09/10/15 on Channels TV, the presenters and their guests were talking about the partial ministerial list and their concerns about the candidates on that list. The candidates on the partial list comprised of former leaders in various aspects of governance of the country in the past administration. It lacked candidates who conform to what I feel is the public’s expectation of “change” and above all, it lacked youthfulness. One of the guests on the show, Professor Christopher Ogbogbo, a professor of History pointed out that “since 1960, we have been recycling the same group of people”. He compared our leaders of the past who were in their youthful age to our current leaders who are mostly in their 50’s and above. He also pointed out that most of our leaders today were indeed the same youths who lead us in the past. This shows us clearly that our youths have indeed being neglected from governance for a very long period.

Nigerian Youths
Nigerian Youths

Pearl S. Buck, a Nobel prize winning writer and novelist once wrote “The young do not know enough to be prudent, and therefore they attempt the impossible, and achieve it, generation after generation”. Due to the nature of our traditions and the reality of the economic situations we experience in our society today, I would like to define the Nigerian youth as any body between the ages of 13 to 35. Tradition was factored into this definition because in most parts in Nigeria, an adult of 35 years old is considered to be relatively young. Due to the harsh realities of living in Nigeria, or a recession hit world at the moment, you can find adults as old as 35 years still living with their parents. Many of these youths are graduates looking for something meaningful to engage themselves in. Pastor Poju oyemade of the covenant christian centre beautifully described this condition as a state of “Learned helplessness”. But despite these short-comings, the Nigerian youth has time and again shown their tenacity to strive and survive in the mist of all the hardships faced in the economy. We have seen local businesses and start-ups spring up from the sheer will and determination of the Nigerian youth especially without support from the Government. The Nigerian youth have also continuously proved their effectiveness in the driving of political campaigns be it on the streets or via social media. So, why have the youths been continually ignored from administration to administration? Why have they been shut out of politics? Is there a lack of confidence in the capabilities of the youths? or Is there a lack of political will to engage the youths in any meaningful decision making process? Perhaps, this is yet another consequence of the long term effect of corruption.

Youths rallying against corruption
Youths rallying against corruption

In Roger hart’s ladder of participation, Tokenism in my opinion was best used to describe the current state of the Nigerian youth in relation to their leaders. Tokenism is where young people (Nigerian youths in this example) appear to be given a voice, but in fact have little or no choice about what they do or how they participate. I chose tokenism because there are various youth groups especially political ones that claim to represent the Nigerian youth, but all they do is “sit on a discussion panel with no substantive preparation and no consultation with their peers”.

Roger hart’s ladder of participation
Roger hart’s ladder of participation

Representing the youth in the governance of Nigeria is no small challenge. it involves figuring out the needs and priorities of the different age groups according to their regions and making sure that their concerns are continually addressed in an efficient manner. Local governments should be legally obligated or empowered to support the youths in their constituency. They should ensure that youths are involved in the decision making processes at that level. This will positively empower the youths by improving their self-esteem and reducing depression thereby encouraging a greater commitment to the community. At this level, the energy, creativity, unique perspectives and propensity for action of the youths should be channelled towards driving real change in the communities.

Most policies made by the government directly affect the youths, so they know first hand the effects of these policies. At the very least, If the Nigerian youths are involved in the decision making process of the government, these policies would be greatly improved upon and the reception of such policies would be positive.

Let me to conclude with these words from Koffi Anan “Young people should be at the forefront of global change and innovation. Empowered , they can be key agents for development and peace. If, however, they are left on society’s margin, all of us will be impoverished. Lets ensure that all young people have every opportunity to participate fully in the lives of their societies.”

My Journey Into Cisco Routing and Switching

As a professional in the IT sector, I’ve always heard the hype about Cisco products and how difficult they were to configure. While looking at job postings, many of them had the CCNA certification as a requirement for consideration. I’ve always wondered why this was the case as most small and medium scale enterprise use a variety of network devices from different vendors. Surely, Cisco cannot have precedence over all of them. I believe one should have a solid understanding of network and system administration principles to be able to build, configure and administer a network environment using any network device available to you. As a result of this orientation, I was always sceptical about taking a Cisco certification.

My first encounter with a Cisco product came while I was employed in a high end nursery school. The proprietor of the nursery had purchased a Cisco 1800 series router and a Cisco adaptive security appliance device together with a couple of Netgear managed switches. I thought to myself, this should all be fairly easy to configure considering the network topology of the nursery.

We decided to create two VLANs to handle data and video services respectively. The managed Netgear switches were very easy to configure as they had a user-friendly Graphical User interface (GUI). All you have to do is to connect a pc to an Ethernet port on the switch and type in an administrative IP address on a web browser and you were in.

VLAN-Membership
Netgear Managed Switch GUI

The Cisco 1800 series router on the other hand was a different kettle of tea. First, you have to connect your pc to the router using a console port cable. Most PCs today do not have a console port, so you have to get a console to USB adapter and install the drivers on your PC before you can attempt a connection. Once the connection was established, I had to figure out how to configure the Cisco router using the command line interface (CLI) as there was no GUI.

cisco
Cisco CLI

I and a colleague of mine carried out some research using Google, the Cisco website and lots of technical blogs out there on the internet. We first had to figure out that some commands run only in privilege mode or in global configuration mode or in interface configuration mode. Then we learnt how to create user names and secret passwords and how to configure access to the router via Telnet and SSH. After that, we decided to use the router as as DHCP server as our windows server had licensing issues at the time. we then figured out how to configure VLANs on the router interfaces and finally, we concluded with the NAT configurations.

Some of the commands we used:

enable
configure terminal
hostname nursery
hostname TTKCRouter
!
enable secret 5 blablahashblah
enable password chima
!
ip dhcp excluded-address 192.168.90.1 192.168.90.50
ip dhcp excluded-address 192.168.50.1 192.168.50.50
!
ip dhcp pool video
network 192.168.90.0 255.255.255.0
default-router 192.168.90.1
dns-server 8.8.8.8
!
ip dhcp pool Data
network 192.168.50.0 255.255.255.0
default-router 192.168.50.1
dns-server 8.8.8.8
!
!
ip cef
multilink bundle-name authenticated
!
!
username chima privilege 15 password 0 blablabla
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
no mop enabled
!
interface FastEthernet0/0.50
encapsulation dot1Q 50
ip address 192.168.50.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface FastEthernet0/0.90
encapsulation dot1Q 90
ip address 192.168.90.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface FastEthernet0/1
ip address 1.2.3.4 255.255.255.252
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
ip forward-protocol nd
!
!
no ip http server
ip nat source list 10 interface FastEthernet0/1 overload
ip nat inside source list 10 interface FastEthernet0/1 overload
ip route 0.0.0.0 0.0.0.0 192.168.2.1
ip route 0.0.0.0 0.0.0.0 1.2.3.5
!
access-list 10 permit 192.168.0.0 0.0.255.255
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
privilege level 15
password #blablabla
login local
transport input all
!
scheduler allocate 20000 1000
end

Passwords and IP address details have been changed

At the end of this scenario, we had a fully configured LAN with access to the internet. My experience with Linux CLI made it easier for me to use the Cisco CLI and I realised that it is much more easier to administer a Cisco device using the CLI.

These challenges convinced me of the necessity to educate myself on Cisco routing and switching technologies. Since then, I have started the CCNA routing and switching course and I have learnt a whole lot about networking in general and Cisco device configuration in particular.

Do your Fucking Research Man…

My mum recently purchased a spanking new HP laptop with model number HP15-d001sia. For some bizarre reason, I felt like this particular HP notebook model was one of the lowest classes of laptops manufactured in terms of its looks and qualities. In fact, it looked so low quality to me that I actually taught it wasn’t a genuine HP product. I didn’t jump to this conclusion based on just the look and feel of the laptop but I arrived at this conclusion during a routine driver update. I was so wrong as it turns out.

a HP laptop
Mom’s HP Laptop with Model number HP15-001sia

You see, this particular laptop came pre-installed with the highly dreaded windows 8 operating system and right off the box, the screen resolution was a bit blurry and the overall performance of the operating system was so poor that the windows performance index was 2.0. I tried to change the screen resolution and found out that I couldn’t because the option to increase or reduce the screen resolution was grayed out. Clearly, this was a display/graphics card driver issue. This particular laptop didn’t come pre-installed with HP drivers, in fact, it didn’t even have any of the bloat-ware crap HP normally ships along with its laptops. It just came pre-installed with the crappy windows 8 operating system and its supported drivers.

So I hurry off to the HP website in search of all the drivers I could get my hands on. I hit the URL http://www.hp.com which then redirects me to the UK version of the site http://www8.hp.com/uk/en/drivers.html. On this site, I type in the model number of the laptop and get the following message:

HP drivers page
Drivers not available

I also tried the method that allows HP automatically detect the PC model but that also yielded the same result. At this point, I concluded that the laptop wasn’t a genuine HP product. But due to my initial bias as too how crappy this laptop looked to me, I ignored the first suggestion HP offered to me:

1. Purchased your product in a different country? Select HP support for that country

Had I followed this link, I would have arrived at the HP website for Africa, and I would have found the model number I was looking for and drivers I needed. But I didn’t, instead, I drove off to confront the guy who sold this laptop to my mum and instantly accused him of selling a fake HP product to my mum because she knows nothing about computers.

In the midst of our argument, we visited the same UK version of the HP website and searched for the drivers and found none. Then the trader typed the model number into Google and arrived straight at the African version of the HP website with all the drivers I needed.

Another HP website
African Version of HP’s Website

At this point, I felt like such a douche for accusing the poor trader of selling fake HP products. I apologized to the man and left the shop feeling so stupid. Why didn’t I even think of consulting the all-knowing Google.

So what’s the moral of this story you might ask?

Do your fucking research before you open your mouth and chat shit!!!

Standards and Regulations: A Panacea to the failed Nigerian Project (Part 1)

According to the ISO, “A standard is a document that provides requirements, specifications, guidelines or characteristics that can be used consistently to ensure that materials, products, processes and services are fit for their purpose.” While a Regulation is a “document providing binding legislative rules, that is adopted by an authority”. Basically, standards ensure that materials, products, processes and services do exactly what they are meant to do while regulations provide legislative powers to authorities that enforce these standards. The advantages and benefits of using standards and regulations include:

  • Support for societal and environmental policies
  • Offers consumer protection
  • Are used across different markets
  • Reflect the state of the art
  •  Disseminate new technologies
  •  Are used for conformity assessment to enhance confidence

Source: Using ISO and IEC standards for technical regulations

Nigeria claims to be the largest economy in Africa based on its rebased GDP even though ordinary Nigerians can’t attest to the benefits of such an economy. One of the reasons for rebasing Nigeria’s GDP was to take into account the growth in certain sectors of the Nigerian economy since the last time it was rebased in 1990. Some of the major economic sectors in Nigeria include telecommunication, manufacturing, oil and gas, transport, Entertainment, health, agriculture and Power amongst others. Although the growth in some of these sectors of the Nigerian economy is undeniable, the impact of such growth is not felt by ordinary Nigerians. There are various reasons why the impact of the economic growth is not felt by ordinary Nigerians, corruption being the major reason, but the lack of standards, its implementation and regulation in these economic sectors is an equally important reason. This part of the article will focus on three of the most important economic sectors in Nigeria and their regulators i.e. food/drug consumption, telecommunication and power. Subsequent parts of this article will cover other sectors and their regulators. Continue reading “Standards and Regulations: A Panacea to the failed Nigerian Project (Part 1)”

The Big Questions

This is one of my favourite episodes on the big questions. I wish the program is aired in Nigeria, we need the enlightenment.

Okey Chima

Sorting out the Issue with Windows 7 desktop and program icons appearing as Microsoft Word 2010

The organization I currently work for have a couple of laptops running windows 7 home edition. Recently one of my colleague brought in one of the laptops as it was experiencing a peculiar problem. All the program icons and the files on the desktop, task bar and the start menu had all changed to the Microsoft word 2010 icon. When you try to open any of these files and icons, they all open up the Microsoft word 2010 program and display gibberish.

This was the first time I had experienced such an issue, so naturally, I checked Google to see what they had to say about it. As it turns out, this was a common issue experienced by a couple of Microsoft users. The first site I visited in search of a solution to this problem was a Microsoft support site and sure enough, they had a couple of suggestions to try out. The first option involved running an automatic fix it add-on but that was not applicable in this case as I was checking for a solution from a different laptop. The second option on the article involved fixing it yourself. This option included the following instructions: Continue reading “Sorting out the Issue with Windows 7 desktop and program icons appearing as Microsoft Word 2010”

I love these Game of Thrones House banners. I can’t wait to start the new season

House of Tyrell
House of Tyrell – Growing Strong

 

House of Greyjoy - We do not sow
House of Greyjoy – We do not sow

 

House of Arryn - As high as Honor
House of Arryn – As high as Honor

 

House of Lannister - Hear me Roar
House of Lannister – Hear me Roar

 

House of Martell - Unbowed, Unbent, Unbroken.
House of Martell – Unbowed, Unbent, Unbroken.

 

House of Baratheon - Ours is the fury
House of Baratheon – Ours is the fury

 

And Finally, my favourite House

House of Stark - Winter is coming
House of Stark – Winter is coming

SPYNET

“Spynet”, that’s what I like to call the internet these days because pretty much everything we do on it is monitored or censored in one way or another. These activities that we carry out on the internet are also stored after being monitored, then the data is mined, analysed and studied even further. The resulting information is used to create a filter bubble of different sorts depending on the internet profile that is created for you. Many people do not even know that they are living in some sort of filter bubble on the internet. This filter bubble was created at the cost of our privacy. Our privacy as we know it on the internet does not exist any more. What we have today is an illusion of privacy. So how did the internet lose its innocence and transformed into the “Spynet”? Continue reading “SPYNET”

Blog at WordPress.com.

Up ↑

%d bloggers like this: